Erkennung von Korrespondeten und Tags neu ausführen lassen

Guten Morgen!

Nachdem ich nun über 2000 PDFs in der DB habe, habe ich bei der Erkennung noch einiges verändert. Vor allem bei Korrespondeten trage ich folgendes ein:

  • Irgendein Wort: die ATU des Unternehmen

Die ATU ist zu 100% nur auf der korrekten Rechnung.

Ein erneutes taggen starte ich so:
docker exec paperless /usr/local/bin/python3 /usr/src/paperless/src/manage.py document_retagger -c -T -t -s -f

Dennoch erkennt er die Rechnungen nicht. Ist der ssh Befehl falsch?

Danke!

Hallo,

was ist denn die Ausgabe deines Befehls? Wird der retagger erfolgreich aufgerufen?

In meinem Chat Sheet habe ich den Retagger ebenfalls stehen, allerdings wird er dort wie auch in der Dokumentation von paperless-ngx über docker-compose und dann den Namen des Containers aufgerufen:

Wenn du einen Container namens „paperless“ am Laufen hast, sollte es aber auch direkt über docker klappen.

Poste doch einmal die Ausgabe des Befehls, evt. sieht man da mehr.

Hallo @Stefan

Danke für die schnelle Reaktion. Habe eventuell das Problem nun gefunden:
ich muss --use-first angeben. Wenn ein automatisch gelernter auch in Frage kommt, macht er gar nichts.

Dann habe ich gesehen das er automatisch immer wieder einen Korrespodent taggen möchte, obwohl ich diesen von Automatisch bereits auf Exakt ungestellt habe. Habe diesen nun auch gelöscht und nun scheint er richtig zu taggen.

Läuft gerade :slight_smile: das dauert nun etwas

edit: hab dann gesehen das man die ID angeben kann. Im Webbrowser sehe ich die ID und konnte dann nur mit einer Rechnung testen. Ging 1000x schneller natürlich :slight_smile:
Wenn er nichts tagged, erhalte ich keine Ausgabe. Sonst steht was er macht

Das wundert mich. Ich bin davon ausgegangen, dass der Parameter -f bereits dafür sorgt, dass vorhandene Klassifizierungen gelöscht werden.

Aber wenn das in Kombination mit dem Löschen des Korrespondenten Hilfe gebracht hat, ist das natürlich ein wertvolles Feedback für andere, die ein ähnliches Problem haben :slight_smile:

Hab es schnell nochmal getestet. Habe für eine Rechnung 2 Korrespondenten angelegt. Also zwei Treffer:
ohne --use-first:


da macht er nichts
mit --use-first:

Da weißt er einen zu. Zufällig den korrekten.

Hi Stefan!
Zumindest bei mir muss es

sudo docker compose exec webserver document_retagger [-h] [-c] [-T] [-t] [-s] [-i] [–use-first] [-f]

heißen. Ohne den „-“. Sonst tut er es nicht. Irgendwas wurde da wohl verändert.
VG

Wenn ich mir die Screenshots ansehe und die Tatsache das docker-compose nicht funktioniert ( ich glaub das ging bei älteren Docker Versionen so ) komm ich zu dem Entschluss das du definitiv kein Synology NAS nutzt oder ? :smiley:

Ich hab hier noch 3 Debian Basierte Systeme und dort läuft docker-compose auch nur mit „-“

Hi Michael!
Ja, das stimmt - ich nutze Paperless in einer Ubuntu VM. Dann ist der Befehl dort offenbar anders.
Viele Grüße